fbpx

Conexión vía SSH

  • Conexión vía SSH

     Noel Urbina Actualizado 2 meses 2 Miembros · 3 Publicaciones
  • Jesica Paola Hernández Bautista

    Miembro
    20 julio, 2021 en 10:04 pm

    No puedo realizar la conexión SSH desde la terminal de mi computadora. Traté de hacer la conexión siguiendo los pasos del video pero no lo logré. Traté de hacer con los pasos del PDF pero tampoco. El problema es que me niega el permiso para hacer la conexión.

    Tengo ambas terminales abiertas, como se indica en el video. A la derecha tengo la terminal de la máquina virtual donde solicité la dirección IP. Si fuera un problema de la contraseña ni siquiera podría logearme.

    Ojalá me puedan ayudar, saludos!

  • Noel Urbina

    Moderador
    21 julio, 2021 en 1:39 pm

    Hola Jessica, lo primero que debes validar es que en tu máquina virtual de Ubuntu tengas instalado openssh-server, y lo puedes realizar ejecutando este comando “<font face=”inherit”>dpkg –list | grep openssh“. Una vez que hayas validado, y si no </font>está<font face=”inherit”> instalado </font>podrías<font face=”inherit”> instalarlo de la siguiente manera “sudo apt install openssh-server“.</font>

    Una vez que se validó lo anterior, podría ser tema de configuración del servicio, ya sea que la conexión sea rechaza al no permitir contraseña o configuración con el firewall.

    La configuración de ssh la puedes encontrar en /etc/ssh/sshd_config y descomenta esta linea para que se habilite el puerto por defecto de ssh que es el 22, guardar la configuración y reiniciar el servicio con el siguiente comando sudo systemctl restart ssh.service e intenta conectarte de nuevo via ssh.

    Por ultimo, si es tema de firewall, instala ufw y realiza los siguientes comandos:

    sudo apt install ufw # Instalar UFW (administrador de firewall)

    sudo ufw enable # Habilitar UFW

    sudo ufw allow ssh # Permitir acceso mediante SSH

    sudo ufw reload # Recargar la configuración

    sudo ufw app list # Validar que se haya agregado

    En caso de no haber funcionado el 3er comando puedes realizar algunos de los siguientes.

    sudo ufw allow 22/tcp

    sudo ufw allow 22/tcp comment ‘Open port ssh tcp port 22’

    Con esto debería dejarte conectar, cualquier duda me los haces saber por aqui o por el chat.

  • Noel Urbina

    Moderador
    21 julio, 2021 en 1:41 pm

    Los adjunte como archivo, pero aqui estan las imagenes

Visualización de 1 - 3 de 3 respuestas

Publicación original
0 de 0 Publicaciones Junio 2018
Ahora